[DS] Desert Storm GTA Clan


 
HomePortalCalendarGalleryFAQSearchMemberlistUsergroupsRegisterLog in

Share | 
 

 Can't play SA:MP

View previous topic View next topic Go down 
AuthorMessage
chillin
V.I.P Very Important Person


Posts : 48
Join date : 2012-11-25

PostSubject: Can't play SA:MP   Thu Jul 11 2013, 17:56

Hi there - suggestions, ideas, tips are all welcome since I'm really lost.

I'm facing that known issue where my LMB (Left Mouse Button) doesn't work in SA:MP. So, I can't shoot or click options in the 'Esc' menu - but SA:MP does load.

I looked it up on SA:MP's forums and it can happen in Windows XP SP 3 onwards (including Windows 7, which I have). For whatever reason, when the application loads, the mouse isn't detected. It makes sense since sometimes it's my entire mouse which doesn't respond - not just the LMB.

To get around it, Alt+Tabbing works for some people (it doesn't for me) or running GTA_SA.exe in compatibility with Windows 98/ ME and as administrator (this does work for me). The thing is, when I run it as the latter and then click 'Connect' on the server, single player loads - not SA:MP. I've tried renaming the directory, which then loads SA:MP but the compatibility and run settings all reset and I face the LMB problem again.

So: In order to fix the LMB button issue, I run in Windows 98/ ME mode - which causes single player to load when I connect to a server in SA:MP. To fix this, I rename the directory and I face the LMB issue again, since the Windows 98/ ME settings have become unchecked.

When I used to play SA:MP, it used to be on Windows 7 also. Do you know what's wrong?
Back to top Go down
View user profile
A[d]renalINe
Desert Storm Member
avatar

Posts : 555
Join date : 2012-07-01
Age : 21
Location : Bosnia and Herzegovina
Job/hobbies : Veterinary Technician

PostSubject: Re: Can't play SA:MP   Thu Jul 11 2013, 18:10

Dude that sucks

_________________
Respect me and I will respect you, disrespect me I'll fuck u up
Back to top Go down
View user profile
[DS]Stormy_Wolf
Main Owner
avatar

Posts : 1175
Join date : 2012-06-30
Age : 23
Location : Germany
Job/hobbies : Student of Computer Sciences

PostSubject: Re: Can't play SA:MP   Thu Jul 11 2013, 21:11

You might have heard this a thousand times already but try to delete your gta_sa.SET file in the GTA San Andreas User Files directory because it stores all information available for GTA SA and SA-MP (Graphic card settings, Processor etc.). It seems to be a driver problem with your mouse. Have you installed new hardware lately ? Or changed your system configuration?

_________________


° Main Owner + Creator of Desert Storm

° Any Questions? Please ask.

° [DS] Online

° Admin Level 10






Credits to [DS]S.W.A.T4 for this signature !


PC Specs:

Processor: AMD FX-8350 8x4 GhZ Octa-Core

ATI Radeon R9 280x 3GB GDDR5 RAM

16GB 1333MhZ DDR3 RAM

GIGABYTE Motherboard UEFI BIOS
Back to top Go down
View user profile http://desertstorm-gtaclan.privetbb.com
Sam



Posts : 79
Join date : 2013-07-10
Age : 19
Location : Vorden, The Netherlands
Job/hobbies : Scripting, PC

PostSubject: Re: Can't play SA:MP   Thu Jul 11 2013, 21:25

Indeed, what Stormy said is true, it could be your answer!

Sam
[DS] Member & Administration Applicant
Back to top Go down
View user profile http://www.battlefieldfans.eu
chillin
V.I.P Very Important Person


Posts : 48
Join date : 2012-11-25

PostSubject: Re: Can't play SA:MP   Thu Jul 11 2013, 22:25

[DS]A[d]renalINe wrote:
Dude that sucks
Tell me about it!

[DS]Stormy_Wolf wrote:
You might have heard this a thousand times already but try to delete your gta_sa.SET file in the GTA San Andreas User Files directory because it stores all information available for GTA SA and SA-MP (Graphic card settings, Processor etc.). It seems to be a driver problem with your mouse. Have you installed new hardware lately ? Or changed your system configuration?

I've put together a new gaming laptop, so all of the hardware is new in a sense. But I have tested the drivers for all the hardware components - the mouse hasn't presented any issues in other games. Plus, no troubleshooting required for anything under 'Device Manager'. The hard drive was brand new, meaning my SA:MP installation was fresh (no old gta_sa.set lingering around from previous installations). I will try opening my gta_sa.set with notepad, editing some variables and seeing if I can get some results.

It's really bugging me though, since SA:MP is a pretty cool game. Thank you for the suggestions and ideas. Any further help is still appreciated.

EDIT: Found a solution. Pasting a certain .dll file into San Andreas directory resolves every aforementioned problem.

The .dll file is 'dinput8.dll'. You can download it for free here: http://www.dll-files.com/dllindex/dl....shtml?dinput8. Directly extract it to your GTA SA directory or copy and paste it there - either way.

If you want to know what exactly you're downloading and inserting, you can read the file's purpose here: http://www.processlibrary.com/direct...dinput8/21771/.

I'm posting this here since it might prove to be helpful to someone else. Much appreciated.
Back to top Go down
View user profile
A[d]renalINe
Desert Storm Member
avatar

Posts : 555
Join date : 2012-07-01
Age : 21
Location : Bosnia and Herzegovina
Job/hobbies : Veterinary Technician

PostSubject: Re: Can't play SA:MP   Fri Jul 12 2013, 09:24

Question answered

_________________
Respect me and I will respect you, disrespect me I'll fuck u up
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: Can't play SA:MP   

Back to top Go down
 
Can't play SA:MP
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Grade 12s who are going on to play post-secondary, AAA/AA/A
» Proxyservice to play WOTLK on european servers
» battlefield play 4 free
» lets play a game, its called lame excuse
» Those who play Tf2 or interested in Tf2

Permissions in this forum:You cannot reply to topics in this forum
[DS] Desert Storm GTA Clan :: General :: General :: Questions and Help-
Jump to: